Kuidas installida rööpad Ubuntu ja värskendada Ruby uusimale versioonile

Paar kuud tagasi, kui ma esimest korda Ruby-on-Rails'i õppisin, pidin töötama koos kodeerimispartneriga koostööprojekti kallal. Meil tekkis pidevalt probleeme, kuna tal oli projekti jaoks Railsi ja Buby seadistustest erinev versioon. Ma ei suutnud oma pead ümber keerata, kuidas projektile vajalikke versioone installida.

Siin on juhend, mida ma sooviksin. Samuti näitab see, kuidas vahetada kasutatava Ruby või Rails versiooni, olenevalt projektidest, millega töötate.

Esmalt installime Ruby uusima versiooni. Selleks peame installima paketi nimega RVM - Ruby version manager. See pakett võimaldab meil installida mis tahes versiooni Ruby meie Ubuntu masinasse ja võimaldab meil versioonide vahel vahetada.

Kogu siin olev kood käivitatakse Ubuntu CLI / terminali abil.

RVM-i installimine

  1. Esiteks peame installima eeltingimuse. Avage oma Ubuntu terminal ja tippige käsk:
sudo apt-get install software-properties-common 

Järgmisena peame lisama PPA (isikliku paketi arhiiv) . PPA on see, kuidas saame arendajate levitatavad failid, mis pole veel jõudnud ametlikku Ubuntu paketti / rakenduste poodi.

See on ka viis, kuidas arendajad levitavad oma tarkvara uusimaid versioone, oodates, kuni Ubuntu seda tarkvara ametlikus poes testib ja avaldab.

sudo apt-add-repository -y ppa:rael-gc/rvm

Ülaltoodud käsk lisab PPA nende kohtade loendisse, kust saame pakette alla laadida meie Ubuntu masinas.

Järgmisena värskendame pakettide loendit käivitades:

sudo apt-get update

Lõpuks installime RVM-i ise.

sudo apt-get install rvm

Nüüd muutuste jõustumiseks taaskäivitage terminal. Seejärel tippige rvm versionja vajutage, enteret kontrollida, kas rvm on installitud. Peaksite saama sellise vastuse:

rvm 1.29.10 (manual) by Michal Papis, Piotr Kuczynski, Wayne E. Seguin [//rvm.io]

Rubiini installimine

Nüüd saame installida uusima Ruby versiooni, mis on 2.7.1. Käivitage käsk rvm install 2.7.1. Teise võimalusena võite käivitada selle, rvm install rubymis installib uusima stabiilse versiooni (see installib v2.7.0).

Installitud Ruby versioonide nägemiseks käivitage rvm ls. Ruby versioonide vahel vahetamiseks käivitage rvm use (näiteks rvm use 2.7.1).

Ruby-on-Rails paigaldamine

Railsi viimane versioon on kell 6.03. Rails on lihtsalt Ruby pärl ja kui Ruby on installitud, saame Rails paigaldada! Käivitage gem install railsRailsi uusima versiooni installimine.

Lõpuks, et kontrollida, kas kõik sujus, jookse rails -v. Peaksite Rails 6.0.3.2tagasi pöörduma, kuna see on selle artikli avaldamise ajal uusim versioon.

Nüüd saate oma esimest Railsi projekti alustada, tippides rails new myapp.

Hei, sa oled nüüd Railsil!